Animal Planet HD nykii VDR:llä

HD materiaali 720p/1080i/1080p. Toisto, tallennus & softat.
Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Animal Planet HD nykii VDR:llä

Viesti Kirjoittaja noeikujoo » 19.01.2010 15:43

Loppukuun ajan Lumon kaapeliverkoissa näkyy ilmaiseksi Animal Planet HD, jota olen katsellut parina iltana. Muuten kanava näkyy hyvin, mutta kuva nykii ajoittain. SD-kanavilla ja muilla HD-kanavilla (Nelonen HD- ja Suomi TV HD) nykimistä ei esiinny. Outputtina VDR-palvelimessa toimii xineliboutput ja kuvaa katsotaan olkkarin koneella vdr-sxfe:n kautta. Voisikohan nykiminen johtua dvb-tekstityksestä? Noilla muilla HD-kanavilla teksitys on "poltettu" kuvaan.

P.Kosunen
Yli-ihminen
Viestit: 1144
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Viesti Kirjoittaja P.Kosunen » 19.01.2010 16:31

Onko miten vanha xine-lib? Julian teki H.264 decoderin kokonaan uusiksi viikko sitten, tuo paransi HD-kanavien toimivuutta ainakin ilmaisten osalta (aiemmin jumitti hd:lle vaihtaessa, frontendin restartin jälkeen toimi).

http://hg.debian.org/hg/xine-lib/xine-lib-1.2/
http://hg.debian.org/hg/xine-lib/xine-l ... 1524dd0f5f

Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Viesti Kirjoittaja noeikujoo » 19.01.2010 17:53

Xine-lib on jotain pari kuukautta vanha ja siihen on asennettu rofaforin tekemä pätsi, jolla saa VDPAU:n kanssa studio levelit käyttöön. Mitään jumiongelmia ei ole ollut. Pitää nyt katsoa jaksaako tuota kokeilla.

Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Viesti Kirjoittaja noeikujoo » 30.01.2010 12:15

Kokeilin uusinta xine-lib-1.2-vdpau:ta, mutta sen kanssa Animal Planet HD nyki vielä enemmän. Vasta kun laitoin vdpau:n deinterlace metodiksi 'bob', nykiminen loppui lähes kokonaan. Lisäksi .xine/config_xineliboutput:n video.output.vdpau_studio_levels -asetus ei jostain syystä näyttänyt toimivan, joten palautin edellisen version käyttöön.

Avatar
rofafor
Optikkoliikkeen kopiovastaava
Viestit: 1365
Liittynyt: 26.03.2004 3:00
Paikkakunta: Internet

Viesti Kirjoittaja rofafor » 30.01.2010 14:49

noeikujoo kirjoitti:Lisäksi .xine/config_xineliboutput:n video.output.vdpau_studio_levels -asetus ei jostain syystä näyttänyt toimivan, joten palautin edellisen version käyttöön.
Tämä kannattaisi debugata kuntoon, jos ongelma on tosiaan virallisessa xine-lib-1.2:ssa.

Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Viesti Kirjoittaja noeikujoo » 30.01.2010 15:21

Asensin xine-lib-1.2-vdpau:n näin:

Koodi: Valitse kaikki

# mkdir xine-lib
# cd xine-lib
# hg clone http://hg.debian.org/hg/xine-lib/xine-lib-1.2-vdpau
# cd xine-lib-1.2-vdpau
# fakeroot debian/rules binary
# cd ..
# sudo dpkg -i *.deb 
Lopuksi käänsin vdr-sxfe:n uudestaan.

Koodi: Valitse kaikki

# cd vdr-xineliboutput
# make clean
# sudo make
# sudo make install
Kai tuo meni ihan oikein? Vanha xine-lib-1.2 oli asennettu siten, että käänsin sen ensin ja sitten ajoin sudo make install ja sudo ldconfig. Oliskohan se pitänyt ensin uninstalloida? Poistin (dpkg -r) nuo uudemmat libxine2-paketit ja palautin vanhan xine-lib:n em. menetelmällä.

P.Kosunen
Yli-ihminen
Viestit: 1144
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Viesti Kirjoittaja P.Kosunen » 30.01.2010 15:56

Manuaalisesti asennettu saattaa mennä /usr/local alle.

Koodi: Valitse kaikki

hg clone http://hg.debian.org/hg/xine-lib/xine-lib-1.2
cd xine-lib-1.2
-vdpau haara yhdistettiin 1.2:een.

Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Viesti Kirjoittaja noeikujoo » 22.03.2010 23:13

rofafor kirjoitti:
noeikujoo kirjoitti:Lisäksi .xine/config_xineliboutput:n video.output.vdpau_studio_levels -asetus ei jostain syystä näyttänyt toimivan, joten palautin edellisen version käyttöön.
Tämä kannattaisi debugata kuntoon, jos ongelma on tosiaan virallisessa xine-lib-1.2:ssa.
Asetus näyttäis toimivan uusimmassa xine-lib-1.2 versiossa, jonka päivitin viime viikolla. Ilmeisesti kun viimeksi kokeilin tuota, niin silloin käytössä olikin luultavasti manuaalisesti asennettu pätsätty versio, jossa studiotasot kiinteästi päällä.

Vastaa Viestiin