BluRay ja MythTV

HD materiaali 720p/1080i/1080p. Toisto, tallennus & softat.
P.Kosunen
Yli-ihminen
Viestit: 1136
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Viesti Kirjoittaja P.Kosunen » 14.01.2010 15:07

~/.xbmc/userdata/Lircmap.xml

Koodi: Valitse kaikki

<lircmap>
	<remote>
		<obc1>SUBTITLES</obc1>
		<obc2>INPUT</obc2>
	</remote>
</lircmap>
~/.xbmc/userdata/keymaps/keyboard.xml

Koodi: Valitse kaikki

<keymap>
	<global>
		<universalremote>
			<obc1>NextSubtitle</obc1>
			<obc2>AudioNextLanguage</obc2>
		</universalremote>
	</global>
</keymap>
Noilla saa suoraan nappeihin.

Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Viesti Kirjoittaja noeikujoo » 14.01.2010 15:15

P.Kosunen kirjoitti:~/.xbmc/userdata/Lircmap.xml

Koodi: Valitse kaikki

<lircmap>
	<remote>
		<obc1>SUBTITLES</obc1>
		<obc2>INPUT</obc2>
	</remote>
</lircmap>
~/.xbmc/userdata/keymaps/keyboard.xml

Koodi: Valitse kaikki

<keymap>
	<global>
		<universalremote>
			<obc1>NextSubtitle</obc1>
			<obc2>AudioNextLanguage</obc2>
		</universalremote>
	</global>
</keymap>
Noilla saa suoraan nappeihin.
Pitääpä testata. Kokeilin kerran tuota, mutta en saanut jostain syystä toimimaan.

P.Kosunen
Yli-ihminen
Viestit: 1136
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Viesti Kirjoittaja P.Kosunen » 14.01.2010 16:01

Monissa ohjeissa sanotaan keymap.xml, mutta tuo vaihtui 9.11 versiossa keyboard.xml:ksi.

Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Viesti Kirjoittaja noeikujoo » 14.01.2010 23:17

Kiitti vinkistä. Nyt ääniraita ja tekstitys vaihtuvat suoraan kaukosäätimen napeista.

Vaikka tämä ei liity mitenkään viestiketjun otsikkoon, niin tässä olisi oma vinkkini edellisen vinkin johdosta:

~/.xbmc/userdata/advancedsettings.xml

Koodi: Valitse kaikki

<advancedsettings>
 <video>  
     <highqualityscaling>1</highqualityscaling>
     <highqualityscalingmethod>8</highqualityscalingmethod>
  </video>
</advancedsettings>
Tuolla saa laadukkaamman ohjelmistopohjaisen skaalauksen päälle XBMC:ssä.

Julmuri
Vanhempi harrastaja
Viestit: 79
Liittynyt: 25.02.2009 12:42

Viesti Kirjoittaja Julmuri » 15.01.2010 0:32

BluRay-asema tuli ja tässä on testailtu nyt parina iltana lyhyesti... tein ripin anydvd/clownbd-yhdistelmällä, testivideona No country for old men josta säilytin molemmat ääniraidat ja yhden tekstitystiedoston. Kaikki ilman muutoksia m2ts-tiedostoon.

Lopputulos: Mplayerissä toimii, mutta tekstityksiin ei pääse käsiksi. VLC toistaa mutta pätkii. MythTV:n sisäinen playeri yrittää avata mutta kaatuu saman tien, käytössä 0.22 avenardin stable-repon pätseillä. Mitäköhän tuossakin tuli tehtyä väärin... teen nyt uutta rippiä mistä jätin toisen ääniraidan pois ja laitoin äänen asetukseksi "core". Ei ehdi enää tänään testaamaan mutta josko huomenna sitten lisää...

P.Kosunen
Yli-ihminen
Viestit: 1136
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Viesti Kirjoittaja P.Kosunen » 15.01.2010 14:35

noeikujoo kirjoitti:Tuolla saa laadukkaamman ohjelmistopohjaisen skaalauksen päälle XBMC:ssä.
GT 220 kanssa pitäisi saada VDPAU HQ-scalingit käyttöön, mutta optio ei näy asetuksissa.

Avatar
noeikujoo
Yli-ihminen
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Viesti Kirjoittaja noeikujoo » 15.01.2010 15:56

P.Kosunen kirjoitti:GT 220 kanssa pitäisi saada VDPAU HQ-scalingit käyttöön, mutta optio ei näy asetuksissa.
VDPAU HQ Upscaling-option on tarkotuksella piilotettu käyttöliittymästä, koska XBMC:n kehittäjät eivät ilmeisesti ehtineet testata sitä kunnolla ennen 9.11 "Camelot":n julkaisua -> http://xbmc.org/trac/changeset/25025.

Ilmeisesti sen voi kuitenkin kytkeä päälle ~/.xbmc/userdata/advancedsettings.xml -tiedoston kautta:

Koodi: Valitse kaikki

<advancedsettings> 
   <videoplayer>
      <vdpauUpscalingLevel>true</vdpauUpscalingLevel>
   </videoplayer>
</advancedsettings> 

Julmuri
Vanhempi harrastaja
Viestit: 79
Liittynyt: 25.02.2009 12:42

Viesti Kirjoittaja Julmuri » 16.01.2010 1:00

Joo-oh... näyttäisi siltä että Mythtv:ssä on pientä ongelmaa noiden isojen tiedostojen kanssa. En pysty Mythtv:n omalla playerillä avaamaan yhtäkään tekemääni rippi-yritelmää, ei M2TS:nä eikä MKV:nä. Kaikissa mukana kuva ja ääni ilman uudelleenpakkaamista... yrittää avata niin hetken please waitin jälkeen palaa menuun. Logiin ilmestyy tällaista...

Koodi: Valitse kaikki

2010-01-14 21:58:42.095 RingBuf(myth://Videos@192.168.0.10:6543/No Country for Old Men/No Country for Old Men.M2TS) Warning: Peek() requested 2048 bytes, but only returning 0
2010-01-14 21:58:42.095 NVP::OpenFile(): Error, couldn't read file: myth://Videos@192.168.0.10:6543/No Country for Old Men/No Country for Old Men.M2TS
2010-01-14 21:58:42.095 TV: StartPlayer(0, Watching Video, main) -- end error
Noh, pakko se on kai sitten toistaiseksi hyväksyä ja muuttaa mplayer-mt:lle... :(

edit: Eikä muuten pysty näköjään kutsumaan edes mplayerin kanssa suoraan frontendistä. :shock:

bent
Säätäjä
Viestit: 321
Liittynyt: 05.06.2009 18:41
Paikkakunta: Turku

Viesti Kirjoittaja bent » 16.01.2010 9:33

mythtv:ssä on se alternate player conffi. Eikös sillä vois pitää sen internalin defaulttina ja sitten poikkeuksien mukaan sitä alternatea ?

En oo kokeillu sitä mut olen nähnyt sellasen asetuksen.

Julmuri
Vanhempi harrastaja
Viestit: 79
Liittynyt: 25.02.2009 12:42

Viesti Kirjoittaja Julmuri » 16.01.2010 13:30

Sitä kokeilin, että määrittelin tiedostotyypille erilaisen konffin. Joskus aikaisemmin käytin sitä kun vakiosoitin ei pystynyt näyttämään videoita kunnolla, silloin mplayer oli määritelty defaultiksi joillekin tiedostotyypeille. Nyt frontend ei vain suostu käynnistämään sitä enää. Kokeilin komentoriviltä niin siinä video aukeaa kyllä nätisti mplayer-mt:llä. Tämä on nyt todella hämärä homma...

Julmuri
Vanhempi harrastaja
Viestit: 79
Liittynyt: 25.02.2009 12:42

Viesti Kirjoittaja Julmuri » 16.01.2010 17:45

Noniin... selvisi sitten tämäkin ongelma. Ei näköjään tavanomaiset oikeudet riitä vaikka kopioin HTPC:n työpöydän kautta tiedoston ulkoiselta kovalevylta (rippaus kun tapahtuu windows-koneella). Luku + kirjoitusoikeudet kaikille niin johan alkoi näkymään. Näyttäisi toimivan nätisti...

Vastaa Viestiin