Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

VDR ja DVB aiheista keskustelua
P.Kosunen
Yli-ihminen
Viestit: 1136
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja P.Kosunen » 04.12.2011 21:42

1.7.22 ei tuonut muutosta ongelmaan.

hetas
Yli-ihminen
Viestit: 540
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja hetas » 05.12.2011 9:58

Minäkin jouduin heittämään komposoinnin pois. Kyllä se aihettaa niin paljon ongelmia.

Kapulaan olen lisännyt painikkeen joka yhdellä painalluksella vaihtaa osd:n softa- ja rautapiirron välillä, pitänee tällä workaroundilla pärjätä toistaiseksi.

Prelude
Säätäjä
Viestit: 237
Liittynyt: 02.02.2007 16:45

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja Prelude » 14.12.2011 22:42

Alkaa olla aika etsiä ongelmalle ratkaisu kun jo X serverinkin alkaa vanhenemaan alta.

[ebuild UD ] x11-base/xorg-server-1.10.4-r1 [1.11.2-r2] USE="ipv6 nptl udev xorg -dmx -doc -kdrive -minimal -static-libs -tslib -xnest -xvfb" 0 kB
[ebuild UD ] x11-drivers/nvidia-drivers-275.09.07 [290.10] USE="acpi (multilib) -custom-cflags -gtk" 0 kB
Total: 2 packages (2 downgrades), Size of downloads: 0 kB

Onkos joku tehnyt raportin NVnews:n foorumille tai jonnekin muualle?

<edit>
Tuli testattua xinelläkin asia ja sama vika silläkin.

hetas
Yli-ihminen
Viestit: 540
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja hetas » 15.12.2011 21:11

Itsekin testailin xine-ui:n Mercurial-versiolla ja sielläkin tosiaan vilkkuu.

Tein tästä bugiraportin xine-projektille:
https://bugs.xine-project.org/show_bug.cgi?id=441

Tuonne kannattaa käydä lisäämässä infoa jos semmosta löytyy.

Laitoin asiasta tietoa myös nvnews.nettiin:
http://www.nvnews.net/vbulletin/showthr ... ost2511166

Onko tuota osd-ongelmaa kukaan huomannut kirjastoilla kuin xinellä?

Prelude
Säätäjä
Viestit: 237
Liittynyt: 02.02.2007 16:45

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja Prelude » 15.12.2011 21:38

Kiitos ja kumarrus Hetas omasta ja varmasti monen muunkin puolesta :-)

P.Kosunen
Yli-ihminen
Viestit: 1136
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja P.Kosunen » 20.01.2012 14:14

xinelib-1.2.0_vdpau_black_frame.patch

Tuolla pätsillä näyttäisi loppuvan välkkyminen.

hetas
Yli-ihminen
Viestit: 540
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja hetas » 20.01.2012 18:33

Meinasin tuota pätsiä testata, mutta asensin ensin uusimmat kehitysversiot xinelibistä ja vdr-sxfe:stä ja vilkkumisongelma näyttää olevan korjattu xinelibbiin.

Pikaisella vilkaisulla tämä kommitti näyttäs liittyvän asiaan:
http://anonscm.debian.org/hg/xine-lib/x ... 3d2caf24da

Itse en noista grafiikkahommista mitään ymmärrä mutta tämä viesti nvnewsissä näyttäisi puhuvan samoista asioista.

P.Kosunen
Yli-ihminen
Viestit: 1136
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja P.Kosunen » 21.01.2012 18:55

Niinpä näkyy toimivan ilman pätsejä.

Prelude
Säätäjä
Viestit: 237
Liittynyt: 02.02.2007 16:45

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja Prelude » 24.01.2012 22:26

Myös täällä homma skulaa jälleen :-)

Kiitos vielä kerran Hetas bugiraporttien luonnista.

Avatar
jarno
Yli-ihminen
Viestit: 527
Liittynyt: 25.06.2005 3:00
Paikkakunta: Tampere

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja jarno » 25.01.2012 14:00

Päivitinpä itsekin xine-libin ja xineliboutputin. Nvidian ajurina on 270.41.06, kannattaako tuota päivittää, eli toimiiko uudemmat paremmin? Näyttis on integroitu GF8300.

Kameleontti
Säätäjä
Viestit: 232
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja Kameleontti » 26.01.2012 12:55

Subit väläyttää kuvaa täälläkin, jos vdr-xineliboutputin asetuksista on käytössä "DVB subtitle decoder: VDR". Myös menuun tulee ilmeisesti subeista johtuvia vihreitä palkkeja. Jos taas käytössä asetus "frontend", niin subit ei näy ollenkaan ja menu pysyy nättinä. Pitäisikö subit näkyä myös "frontend-asetuksella"? Ja saako tuon välkynnän poistettua jotenkin?

Käytössä Gentoo, nvidia-drivers-290.10 ja vdr-testing/vdr-devel overlaysta emergatut xine-lib-1.2.9999 ja vdr-xineliboutput-9999.

EDIT: ja katseluun käytän vdr-sxfe:tä.

P.Kosunen
Yli-ihminen
Viestit: 1136
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja P.Kosunen » 29.01.2012 21:28

Koodi: Valitse kaikki

--hud=xshape
Kokeile tarjota tuo vipu vdr-sxfe:lle.

Prelude
Säätäjä
Viestit: 237
Liittynyt: 02.02.2007 16:45

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja Prelude » 29.01.2012 22:44

Ei apua. Reunat edelleen vihreät.
Tuosta pääsee eroon kun muuttaa OSD:n asetuksista "static transparency correction: arvoon 8 tai suurempi.
Tässäkin tietty on haittansa eli osd:n aikana ainakin pearHD skini himmentää kuvaa jonkin verran ja tämä häiritsee ainakin minua.

Prelude
Säätäjä
Viestit: 237
Liittynyt: 02.02.2007 16:45

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja Prelude » 06.02.2012 1:23

Päivitin 05.02.2012 repo versioihin sekä xine-lib:n että sxfe:n. Edelleen kun kaksi OSD elementtiä tulee päällekkäin tulee alimmaiseen? vihreät reunat kun ne pitäisi olla läpinäkyvät.

Koitin samaa xinellä ja silläkin näyttää tekevän samaa.
Helpoin tämä on testata ylen kanavilla joissa tulee tekstitys ja sitten painaa jotain sen päälle menevää menua näkyviin. (Vaatii tietenkin show all layers asetuksen xineliboutin osd menusta)

Ennenkuin alan tastä bugiraporttia kirjoittelemaan niin voisiko joku muukin kuin kameleontti vahvistaa tämän ongelman?


käytössä: nvidia-drivers-290.10, muut repoista.

Avatar
jarno
Yli-ihminen
Viestit: 527
Liittynyt: 25.06.2005 3:00
Paikkakunta: Tampere

Re: Xineliboutput, vdpau ja dvb-subit/valikot "pätkäisee"

Viesti Kirjoittaja jarno » 06.02.2012 8:35

Prelude kirjoitti: Ennenkuin alan tastä bugiraporttia kirjoittelemaan niin voisiko joku muukin kuin kameleontti vahvistaa tämän ongelman?
xine-1.2 git:stä 25.1, xineliboutput samalta päivältä, nvidian ajuri 270.41.06 ja sama homma. Eli kun katselee yleä ja avaa osd:n niin tekstin reuna muuttuu vihreäksi.

Vastaa Viestiin