Pluginien käännettävyys 1.5.9 ->

VDR ja DVB aiheista keskustelua
Albie
Säätäjä
Viestit: 277
Liittynyt: 28.01.2006 16:44
Paikkakunta: Joensuu

Pluginien käännettävyys 1.5.9 ->

Viesti Kirjoittaja Albie » 30.09.2007 19:02

Klasun tekstitysintegrointia odotellessa ajattelin tehdä vähän galluppia pluginien toimivuudesta 1.5 -sarjan VDR:ssä.

Käytössä on tällä hetkellä 1.4.5 -versio seuraavilla plugineilla:

Koodi: Valitse kaikki

- epgsearch
- rssreader
- femon
- sc
- burn
- subtitles
- ttxtsubs
- osdteletext
- mp3
- streamdev-server
- vompserver
Näistä ainakin seuraaviin olisi näköjään tehty korjaus uusiin versioihin joten pitäisi toimia sen kummemmitta tempuitta uusillakin VDR:n versioilla:

Koodi: Valitse kaikki

- epgsearch
- rssreader
- femon
Nämä käynevät kohtapuoliin tarpeettomiksi:

Koodi: Valitse kaikki

- subtitles
- ttxtsubs
Mutta mitenkäs nämä:

Koodi: Valitse kaikki

- sc
- burn
- osdteletext
- mp3
- streamdev-server
- vompserver
Mitenkäs helposti nämä saisi pelaamaan vai onko tappelua odoteltavissa? Jos jostain löytyy plugareista uutta versiota, joka kääntyisi lokalisointi- ja osd-layer -muutosten jälkeisissä VDR:issä, ottaisin mielelläni vastaan vinkkiä ja linkkiä... :wink:

SC ja Burn ovat noista melko ehdottomia, jotta voisin päivittää 1.5 -sarjaan, mutta muutkin olisi tietysti kiva saada pelaamaan. Kiitoksia jälleen etukäteen...

Avatar
jjkemp
Havittelija
Viestit: 26
Liittynyt: 01.06.2004 3:00
Paikkakunta: Kempele

Re: Pluginien käännettävyys 1.5.9 ->

Viesti Kirjoittaja jjkemp » 30.09.2007 21:52

Albie kirjoitti:Klasun tekstitysintegrointia odotellessa ajattelin tehdä vähän galluppia pluginien toimivuudesta 1.5 -sarjan VDR:ssä.

...

Mutta mitenkäs nämä:

Koodi: Valitse kaikki

- sc
- burn
- osdteletext
- mp3
- streamdev-server
- vompserver
Mitenkäs helposti nämä saisi pelaamaan vai onko tappelua odoteltavissa? Jos jostain löytyy plugareista uutta versiota, joka kääntyisi lokalisointi- ja osd-layer -muutosten jälkeisissä VDR:issä, ottaisin mielelläni vastaan vinkkiä ja linkkiä... :wink:

SC ja Burn ovat noista melko ehdottomia, jotta voisin päivittää 1.5 -sarjaan, mutta muutkin olisi tietysti kiva saada pelaamaan. Kiitoksia jälleen etukäteen...
sc -toimii
burn - toimii
osdteletext - toimii
mp3 - ei kokemusta
streamdev-server - toimii
vompserver - ei kokemusta

burn ja streamdev mulla on aina cvs:stä, muista plugineista tuorein versio. osdteletext oli ainut mikä tarvitsi oman pätsin.

mihatsu
Isäntä
Viestit: 117
Liittynyt: 23.02.2007 20:43
Paikkakunta: Espoo

Re: Pluginien käännettävyys 1.5.9 ->

Viesti Kirjoittaja mihatsu » 30.09.2007 22:47

osdteletext - toimii
Tartteeko tämä jotain batchia?

Itellä kaatuu seuraavaan itkuun kääntö

Koodi: Valitse kaikki

make[1]: *** [txtrecv.o] Error 1

nm
Johtava konsultti
Viestit: 3160
Liittynyt: 22.07.2005 3:00

Viesti Kirjoittaja nm » 30.09.2007 22:53

Vilkaise jjkemp:n viestin viimeistä lausetta

mihatsu
Isäntä
Viestit: 117
Liittynyt: 23.02.2007 20:43
Paikkakunta: Espoo

Viesti Kirjoittaja mihatsu » 30.09.2007 22:56

nm kirjoitti:Vilkaise jjkemp:n viestin viimeistä lausetta
:oops: Sori! Jäi luku kesken kun ihmettelin että miten tuo on saatu toimii :oops:

Albie
Säätäjä
Viestit: 277
Liittynyt: 28.01.2006 16:44
Paikkakunta: Joensuu

Viesti Kirjoittaja Albie » 01.10.2007 15:11

No eipä alkanut lupaavasti, ensimmäinen plugari (Burn) ja heti tökkäsi:

Koodi: Valitse kaikki

make[1]: Entering directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
make[1]: Leaving directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
make[1]: Entering directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
make[1]: *** No rule to make target `boost/bind.hpp', needed by `burn.o'.  Stop.
make[1]: Leaving directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
Eipä tosin näytä kovin tuoreelta tuokaan CVS-versio, uusin tiedosto näyttäisi olavan vajaan vuoden vanha:

Koodi: Valitse kaikki

-rw-r--r--  1 root root  42436 2006-10-24 20:47 i18n.c
-rw-r--r--  1 root root  17897 2006-10-24 20:47 menuburn.c
-rw-r--r--  1 root root   5031 2006-10-24 20:47 menuitems.c
-rwxr-xr-x  1 root root   1394 2006-10-24 20:46 vdrburn-archive.sh*
-rwxr-xr-x  1 root root   9189 2006-10-24 20:46 vdrburn-dvd.sh*
Eikö tuota plugaria enää päivitetä vai haenko CVS-version väärästä paikasta? Nyt käskynä on:

Koodi: Valitse kaikki

cvs -d:pserver:anoncvs@vdr-developer.org:/var/cvsroot login
cvs -z3 -d:pserver:anoncvs@vdr-developer.org:/var/cvsroot co burn
Eli teillä toimii kuin moppe?

(Miksi minä rupesin näihin hommiin, kun näistä ei kuitenkaan tule mitään... :wink: )

mihatsu
Isäntä
Viestit: 117
Liittynyt: 23.02.2007 20:43
Paikkakunta: Espoo

Viesti Kirjoittaja mihatsu » 01.10.2007 16:02

Albie kirjoitti:No eipä alkanut lupaavasti, ensimmäinen plugari (Burn) ja heti tökkäsi:

Koodi: Valitse kaikki

make[1]: Entering directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
make[1]: Leaving directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
make[1]: Entering directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
make[1]: *** No rule to make target `boost/bind.hpp', needed by `burn.o'.  Stop.
make[1]: Leaving directory `/usr/local/src/vdr-1.5.9/PLUGINS/src/burn-cvs'
Eipä tosin näytä kovin tuoreelta tuokaan CVS-versio, uusin tiedosto näyttäisi olavan vajaan vuoden vanha:

Koodi: Valitse kaikki

-rw-r--r--  1 root root  42436 2006-10-24 20:47 i18n.c
-rw-r--r--  1 root root  17897 2006-10-24 20:47 menuburn.c
-rw-r--r--  1 root root   5031 2006-10-24 20:47 menuitems.c
-rwxr-xr-x  1 root root   1394 2006-10-24 20:46 vdrburn-archive.sh*
-rwxr-xr-x  1 root root   9189 2006-10-24 20:46 vdrburn-dvd.sh*
Eikö tuota plugaria enää päivitetä vai haenko CVS-version väärästä paikasta? Nyt käskynä on:

Koodi: Valitse kaikki

cvs -d:pserver:anoncvs@vdr-developer.org:/var/cvsroot login
cvs -z3 -d:pserver:anoncvs@vdr-developer.org:/var/cvsroot co burn
Eli teillä toimii kuin moppe?

(Miksi minä rupesin näihin hommiin, kun näistä ei kuitenkaan tule mitään... :wink: )
Vili veikkaus: Sulta puuttuu boost tai varmaan libboost-dev

Albie
Säätäjä
Viestit: 277
Liittynyt: 28.01.2006 16:44
Paikkakunta: Joensuu

Viesti Kirjoittaja Albie » 01.10.2007 16:47

mihatsu kirjoitti:Vili veikkaus: Sulta puuttuu boost tai varmaan libboost-dev
Veikkauksesi oli hyvinkin kohdallaan... :)

Eli nyt toimii ainakin seuraavat:

Koodi: Valitse kaikki

- sc 
- burn 
- osdteletext 
- streamdev-server 
Eli tuosta Burnista ei siis ole vuotta tuoreempaa versiota?

nolodude
Isäntä
Viestit: 118
Liittynyt: 10.12.2005 23:21
Paikkakunta: Helsinki

Viesti Kirjoittaja nolodude » 06.10.2007 23:09

Text2skin ei käänny VDR 1.5.9: kanssa :(

aaakoo
Vanhempi harrastaja
Viestit: 63
Liittynyt: 02.09.2006 3:04
Paikkakunta: Vaajakoski

Viesti Kirjoittaja aaakoo » 07.10.2007 14:27

nolodude kirjoitti:Text2skin ei käänny VDR 1.5.9: kanssa :(
Kyllä kääntyy mutta pitää vähän säätää:

http://www.linuxtv.fi/viewtopic.php?t=2502

nolodude
Isäntä
Viestit: 118
Liittynyt: 10.12.2005 23:21
Paikkakunta: Helsinki

Viesti Kirjoittaja nolodude » 07.10.2007 18:48

Oho, kiitos!

svalavuo
Säätäjä
Viestit: 286
Liittynyt: 07.12.2004 3:00
Paikkakunta: Rauma
Viesti:

1.5.9 pluginit

Viesti Kirjoittaja svalavuo » 10.10.2007 10:32

Itselläni koneeseen käännettynä 1.5.9 ja seuraavat pluginit

burn
cdda
coverviewer
dvd
epgsearch
femon
games
hattrick
live
music
osdpip
osdteletext
picselshow
sc
skinenigmang
skinsoppalusikka
snapshot
span
streamdev-client
streamdev-server
subtitles
sudoku
ttxtsubs
tvonscreen
undelete
vdrcd
vompserver

Tuossa on muutama turhakin nykyään joukossa, sillä vdrcd ja cdda eivät ole käytössä (music hoitaa homman).
Pientä kipua on DVD -pluginin kanssa välillä, mutta onneksi taloudessa on xbox :)

Parin pluginin kanssa joutui hiukan tappelemaan eikä kaikissa toimi täysin tuo uusi kielisysteemi, mutta yllättävän kivuttomasti tuo onnistui.
Koitan kehittää jonnekin tarinan tuosta asentamisesta ja kääntämisestä.

mihatsu
Isäntä
Viestit: 117
Liittynyt: 23.02.2007 20:43
Paikkakunta: Espoo

Re: 1.5.9 pluginit

Viesti Kirjoittaja mihatsu » 11.10.2007 21:23

svalavuo kirjoitti:Itselläni koneeseen käännettynä 1.5.9 ja seuraavat pluginit

burn
cdda
coverviewer
dvd
epgsearch
femon
games
hattrick
live
music
osdpip
osdteletext
picselshow
sc
skinenigmang
skinsoppalusikka
snapshot
span
streamdev-client
streamdev-server
subtitles
sudoku
ttxtsubs
tvonscreen
undelete
vdrcd
vompserver

Tuossa on muutama turhakin nykyään joukossa, sillä vdrcd ja cdda eivät ole käytössä (music hoitaa homman).
Pientä kipua on DVD -pluginin kanssa välillä, mutta onneksi taloudessa on xbox :)

Parin pluginin kanssa joutui hiukan tappelemaan eikä kaikissa toimi täysin tuo uusi kielisysteemi, mutta yllättävän kivuttomasti tuo onnistui.
Koitan kehittää jonnekin tarinan tuosta asentamisesta ja kääntämisestä.
Mitä tohon tvonscreeniin dumppasit?

spegar
Amatööri
Viestit: 13
Liittynyt: 17.05.2007 16:38

Re: 1.5.9 pluginit

Viesti Kirjoittaja spegar » 11.10.2007 21:44

mihatsu kirjoitti:
svalavuo kirjoitti:Itselläni koneeseen käännettynä 1.5.9 ja seuraavat pluginit

burn
cdda
coverviewer
dvd
epgsearch
femon
games
hattrick
live
music
osdpip
osdteletext
picselshow
sc
skinenigmang
skinsoppalusikka
snapshot
span
streamdev-client
streamdev-server
subtitles
sudoku
ttxtsubs
tvonscreen
undelete
vdrcd
vompserver

Tuossa on muutama turhakin nykyään joukossa, sillä vdrcd ja cdda eivät ole käytössä (music hoitaa homman).
Pientä kipua on DVD -pluginin kanssa välillä, mutta onneksi taloudessa on xbox :)

Parin pluginin kanssa joutui hiukan tappelemaan eikä kaikissa toimi täysin tuo uusi kielisysteemi, mutta yllättävän kivuttomasti tuo onnistui.
Koitan kehittää jonnekin tarinan tuosta asentamisesta ja kääntämisestä.
Mitä tohon tvonscreeniin dumppasit?
tuolla toimii http://toms-cafe.de/vdr/download/tvonsc ... 1.5.3.diff

mihatsu
Isäntä
Viestit: 117
Liittynyt: 23.02.2007 20:43
Paikkakunta: Espoo

Re: 1.5.9 pluginit

Viesti Kirjoittaja mihatsu » 11.10.2007 22:38


Vastaa Viestiin