Vdr-sxfe ja hd-kanavien ääniongelmat

VDR ja DVB aiheista keskustelua
hetas
Yli-ihminen
Viestit: 542
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

Vdr-sxfe ja hd-kanavien ääniongelmat

Viesti Kirjoittaja hetas » 17.06.2018 8:46

Hiljaista on tällä foorumilla ollut, mutta kokeillaan jos löytyisi ideoita.

Käytössä on xineliboutput, vdr-sxfe ja vdpau. Homma toimii muuten hyvin, mutta osalla hd-kanavista äänet toimivat huonosti tai eivät ollenkaan. Ylen kanavat toimivat hyvin, MTV3 HD ei juuri ollenkaan, Nelonen HD huonosti.

MTV3 HD:lle vaihtaessa joku ääni saattaa kuulua, mutta se jälkeen mykistyy. Nelosella ääni saattaa toimia pari minuuttia ja sitten mykistyy. Sama homma livenä tai tallenteissa.

Kodilla samat kanavat ja tallenteet toimivat hyvin. Mieluummin käyttelisin kuitenkin VDR:n omia kaukosäätimen näppäinasetteluja ja -toimintoja.

Sekä vdr-sxfe:ssä, että Kodissa molemmissa on Pulseaudio käytössä. Päällimmäinen epäilys on että xineliboutput pelaa huonommin yhteen Pulseaudion kanssa kuin Kodi. Pulseaudio on aiheuttanut ongelmia ennenkin, mutta se on nyt niin tiukasti Debianin paketoinnissa mukana, että ei jaksaisi ruveta säätämään sitä pois. Ainakin nettiselainten kanssa tuli hankaluuksia ilman Pulseaudiota.

Olen kokeillut myös pasuspenderia ja jotain muita kikkailuja joilla saisi pulseaudion ohitettua, mutta jossain välissä en enää saanut suoraan Alsaa käyttöön.

Eli olisiko ideoita mitäs voisi kokeilla? Tai vaihtoehtoja vdr-sxfe:lle jotka käyttävät VDPAUta ja joita voi ajaa fullscreeninä ja ikkunassa.

Albie
Säätäjä
Viestit: 277
Liittynyt: 28.01.2006 16:44
Paikkakunta: Joensuu

Re: Vdr-sxfe ja hd-kanavien ääniongelmat

Viesti Kirjoittaja Albie » 23.06.2018 11:44

Itse törmäsin samaan ongelmaan, kun asentelin muutama viikko sotten yhden boksin uudelleen uudella distrolla ja VDR:n versiolla ja laitoin samassa rytinässä äänet kuulumaan GeForce 210:n HDMI-liitännästä entisen äänikorttiliitännän kautta. Analoginen ääni toimi entisessä asennuksessa moitteetta ja tietenkin kuvittelin, että joku tuossa distron ja VDR:n päivittämisessä olisi saanut ääniongelman aikaan eikä äänen ottaminen PCM:nä HDMI-liitännästä ja PulseAudion epäyhteensopimattomuus muutokseen. Tänään sain äänet kuulumaan kunnolla, itse asiassa korjaus oli ainakin omassa melkoisen helppo. Lisäsin vdr-sxfe:n käynnistysparametreihin option:

Koodi: Valitse kaikki

--audio=alsa:hw:0,3
Tietysti tuo hw:0,3_n pitää natsata jokaisen omaan laitteestoon ja sen voi katsoa komennolla:

Koodi: Valitse kaikki

aplay -l
Kiitokset johdatuksesta ongelman alkulähteelle!

hetas
Yli-ihminen
Viestit: 542
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

Re: Vdr-sxfe ja hd-kanavien ääniongelmat

Viesti Kirjoittaja hetas » 23.06.2018 15:28

Itsellä on siis hyvin samantapainen setuppi, eli nVidian hdmi-lähtö käytössä. Käyttelin aiemmin tuota alsaa suoraan, mutta se lakkasi toimimasta jostain syystä.

Ehkä testailen vielä jahka jaksan. Mutta kuten todettua, Kodi pelaa Pulseaudion kanssa ihan hyvin.

Vastaa Viestiin