vdr 1.4.7 spids subtitles and ttxtsubs

Juttua VDR:n ja VDR pluginien patcheistä
Avatar
dj
Yli-ihminen
Viestit: 668
Liittynyt: 22.08.2004 3:00

vdr 1.4.7 spids subtitles and ttxtsubs

Viesti Kirjoittaja dj » 06.07.2007 16:24

Löytyykö jostain pätsiä joka toimii vdr 1.4.7:n kanssa? Vain 1.5.2:lle pätsin olen löytänyt. Tallennettu Serranon perhe YLE:llä pätkii kun siinä on kaksi ääniraitaa ja tekstit. Vaimoa kiukuttaa...

Avatar
phelin
Yli-ihminen
Viestit: 1256
Liittynyt: 09.02.2005 3:00
Paikkakunta: Helsinki

Re: vdr 1.4.7 spids subtitles and ttxtsubs

Viesti Kirjoittaja phelin » 06.07.2007 20:36

dj kirjoitti:Löytyykö jostain pätsiä joka toimii vdr 1.4.7:n kanssa? Vain 1.5.2:lle pätsin olen löytänyt. Tallennettu Serranon perhe YLE:llä pätkii kun siinä on kaksi ääniraitaa ja tekstit. Vaimoa kiukuttaa...
Sori, ei ole vastausta, vain kysymyksiä:

1. Mulla ainakin 1.5.2 on ollut todella vakaa ja kaikki käyttämäni pluginit toimivat moitteetta sen kanssa => onko jokin syy mikset siirry käyttämään 1.5.2:sta?

2. Mihin tarvitset spids-pätsiä? Se kun on "kokeellinen"...

PS 1.5.2:lla täälläkin tallennetaan Serranon perhettä ja hyvin on toiminut.

Avatar
dj
Yli-ihminen
Viestit: 668
Liittynyt: 22.08.2004 3:00

Viesti Kirjoittaja dj » 06.07.2007 22:53

Käsittääkseni tarvitsen spidsiä siihen Serranon perheeseen:
http://www.linuxtv.org/pipermail/vdr/20 ... 13442.html
Serranon perheessä toinen ääniraita on tekstitys tietokoneen puhumana ilmeisesti näkörajotteisille.

Jotain salettiin hajoaa kun asennan vdr 1.5 sarjaa... Laite on jokapäiväisessä käytössä ja toimii nyt erittäin hyvin.

Talvella voisi harkita päivitystä kun ulkona on pimeää ja kylmää...

Avatar
phelin
Yli-ihminen
Viestit: 1256
Liittynyt: 09.02.2005 3:00
Paikkakunta: Helsinki

Viesti Kirjoittaja phelin » 07.07.2007 0:39

Toi tekstien tallentumattomuus on hieman kummallista, sillä mulla ei ole sitä koskaan esiintynyt, ja lähes kaikki tallentamani materiaali on Ylen lähettämää ja tekstitettyä. näin myös sekä versiolla 1.4.7 että 1.5.2 ja ilman spids-pätsiä (jota kokeilin jokin aika sitten heikolla menestyksellä, mutta Rofa on muistaakseni päivittänyt sitä sen jälkeen).

Millaista pätkiminen oikein on? Molemmat ääniraidat tallentuvat täällä ok ja niistä voi valita mieleisensä ja tekstitykset toimivat moitteetta. Subtitles-pluginin tekijä Pekka Virtanen tuolla viittaamassasi ketjussa tosin toteaa, että subtitles-plugin ei toimi dynaamisten tekstitysten kanssa aina oikein, mutta minä enn tuota ole siis huomannut. Serrano-tallenteisiin tulee useampi minuutti edeltäviä uutisia, joissa ei taatusti ole testitystä, mutta sillä ei ole ollut merkitystä.

Ehdotin viittaamassasi ketjussa ratkaisuna kiinteiden subtitle-pidien käyttämistä, sillä suomenkielinen tekstitys tulee aina samalla pid:llä (kanavakohtaisesti). Tämä voisi onnistua kommentoimalla rivi 71 (SaveChannels();) subtitles.c:stä ja asettamalla subchannels.conf:tiedostossa kiinteät pidit käyttöön.Eli esim Welholla näin:

Koodi: Valitse kaikki

C-0-1-17:8:fin=1027+1+50+17                                #TV1
C-0-1-33:8:fin=2027+1+50+17                                #TV2
C-0-1-81:8:fin=3027+1+50+17,sve=3028+2+50+17 #FST5 (ruotsi myös)
C-0-1-129:8:fin=5027+1+50+17                              #Extra
C-0-1-145:8:fin=5027+1+50+17                              #Teema
Käytin aikoinaan kyseistä ratkaisua Teemalta tulleen Perhelääkäri-sarjan kanssa, jotta sain sekä suomen- että espanjankieliset tekstitykset talteen.

Avatar
dj
Yli-ihminen
Viestit: 668
Liittynyt: 22.08.2004 3:00

Viesti Kirjoittaja dj » 07.07.2007 1:43

Tekstit tulee talteen ainakin osittain, mutta kuva pätkii ja paukkuu. ja välillä tekstit näkyy ja välillä ei. Tai jotain sinnepäin, täytyy tutkia tarkemmin... Ääniraidat tuntui toimivan.

Avatar
dj
Yli-ihminen
Viestit: 668
Liittynyt: 22.08.2004 3:00

Viesti Kirjoittaja dj » 13.07.2007 23:16

Nyt oli kuulemma sellainen tallennettu Serrano jakso jossa kaikki toimi ihan ok... että ehkäpä vika on jossain muualla... lähetteessä vikaa...?

Avatar
dj
Yli-ihminen
Viestit: 668
Liittynyt: 22.08.2004 3:00

Viesti Kirjoittaja dj » 15.07.2007 23:03

Taas oli Serrano jakso toiminut ilman pätkimistä. Ehkäpä tässä ei mitään pätsejä tarvitakaan...

Avatar
dj
Yli-ihminen
Viestit: 668
Liittynyt: 22.08.2004 3:00

Viesti Kirjoittaja dj » 20.07.2007 16:14

Antennijohto oli rikki... Ehkä se oli vain sellainen sattumaa tämä juttu.

Vastaa Viestiin