Toimiva tv_grab_fi (katso tänne)

Juttua VDR:n ja VDR pluginien patcheistä
Matias
Vastasyntynyt
Viestit: 2
Liittynyt: 31.03.2006 19:10
Paikkakunta: Turku
Viesti:

Toimiva tv_grab_fi (katso tänne)

Viesti Kirjoittaja Matias » 31.03.2006 19:30

Kyllästyin tappelemaan MythTV:n kanssa ja korjailin http://nyt.hs.fi -sivuilta tietonsa hakevan grabberin toimintakuntoon.

Tiedoston löydät täältä:
http://www.matelijat.net/xmltv/tv_grab_fi

Kanavat on nimetty 100, 101, jne, jne..

Jos joku viitsii tehdä grabberista paremman ja "virallisen" version, olisi se kiva saada minullekin. :)

Matias
Vastasyntynyt
Viestit: 2
Liittynyt: 31.03.2006 19:10
Paikkakunta: Turku
Viesti:

Viesti Kirjoittaja Matias » 31.03.2006 19:46

Kröhöm, tarkistakaa kuitenkin, että skripti toimii ennen kuin luotatte siihen. :)


PÄIVITYS: skripti ei toiminut oikein, sillä se laski päivämäärän väärin, jos kuukausi vaihtui. Nyt pitäisi toimia. :)

PS. Alkuperäinen skripti www.nyt.fi -palvelimelle löytyi XMLTV:n bugien joukosta ja päivitin sen vain toimivaksi. Joku saa tehtäväkseen tehdä kunnon korjauksen..

Tässä bugiraportti:
https://sourceforge.net/tracker/?func=d ... p_id=39046

razze
Vastasyntynyt
Viestit: 2
Liittynyt: 03.04.2006 16:52
Paikkakunta: Espoo

Viesti Kirjoittaja razze » 03.04.2006 17:09

Hei!

Ainakin minulla ei kyseinen scripti toimi, ja koska alkuperäinen tv_grab_fi (joka siis käyttää katso.fi:n tietoja) on myös lakannut toimiasta en tällä hetkellä saa mistään ohjelmatietoja koneelleni.

Scripti heittää seuraavan virheen:

Koodi: Valitse kaikki

Undefined subroutine &XMLTV::AskTerm::init called at ../common/tv_grab_fi line 156.
Koska en ole ikinä tehnyt mitään perl-koodia en oikein tiedä mitä tämä virhe tarkoittaa, ja miten sen pitäisi korjata. Kaikki vihjeet otetaan ilomielin vastaan.

Minun pitäisi saada ohjelmatiedot vietyä Freevoon.

Razze
Linux User #393524

AMD Athlon 64 X2 3800+, Asus A8V, VIA K8T800Pro, 2x Samsung SP120 200G sata, Plextor PX-716A, 2x 512MB dual channel DDR

nm
Johtava konsultti
Viestit: 3160
Liittynyt: 22.07.2005 3:00

Viesti Kirjoittaja nm » 03.04.2006 17:26

XMLTV-kirjastosi versio taitaa olla eri, kuin mitä skripti vaatii.

razze
Vastasyntynyt
Viestit: 2
Liittynyt: 03.04.2006 16:52
Paikkakunta: Espoo

Viesti Kirjoittaja razze » 03.04.2006 18:40

Hei!

Kiitoksia vinkistä. Se oli juuri ongelmana. Päivitin XMLTV ja sillä sain ohjelmaoppaan toimimaan taas!

t.
Razze
Linux User #393524

AMD Athlon 64 X2 3800+, Asus A8V, VIA K8T800Pro, 2x Samsung SP120 200G sata, Plextor PX-716A, 2x 512MB dual channel DDR

heisti
Vastasyntynyt
Viestit: 1
Liittynyt: 09.04.2006 22:01
Paikkakunta: Kuopio

Viesti Kirjoittaja heisti » 09.04.2006 22:13

razze kirjoitti:Hei!

Kiitoksia vinkistä. Se oli juuri ongelmana. Päivitin XMLTV ja sillä sain ohjelmaoppaan toimimaan taas!

t.
Razze
Mulla taitaa olla samanlainen ongelma. Kerrotko miten tuo XMLTV päivitetään?

Avatar
jarno
Yli-ihminen
Viestit: 527
Liittynyt: 25.06.2005 3:00
Paikkakunta: Tampere

Viesti Kirjoittaja jarno » 09.04.2006 22:29

heisti kirjoitti:Kerrotko miten tuo XMLTV päivitetään?
Jos olet asentanut distron pakettien hallinnalla niin sillä se päivitetään, jos olet kääntänyt itse niin käännä uudempi versio. (?)
/jarno

Vastaa Viestiin