Sivu 11/11

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 01.06.2017 21:18
Kirjoittaja diudiu
Moro,

taitaa ruudussa olla taas jotain muuttunut, ei löydä jaksoja...

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 03.06.2017 17:14
Kirjoittaja antoine
Taas kerran päivitetty.

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 31.07.2017 17:43
Kirjoittaja diudiu
Ei taida oikein pelittää uusimman yle-dl:n kanssa...

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 01.08.2017 17:58
Kirjoittaja antoine
Nyt pitäisi toimia. Tekstitykset aiheuttivat paljon päänvaivaa, joten siirsin niiden käsittelyn kulkemaan ffmpegin kautta.

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 02.08.2017 2:46
Kirjoittaja diudiu
Joo, kyllähän tuo auttoi kun käytetään vanhempaa yle-dl:ää (2.17). Nykyisin siinä mennään jo versiossa 2.21 ja sen kanssa homma ei tunnu toimivan.

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 08.08.2017 21:10
Kirjoittaja antoine
Nyt pitäisi toimia 2.21-version (muttei enää vanhempien) kanssa.

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 14.08.2017 16:03
Kirjoittaja Rene
Toimiiko muilla vhs normaalisti? Saan seuraavan virheen Late Lampaan ja myös muiden Yle:n ohjelmien kohdalla:
Koodi: Valitse kaikki
Late lammas (1-2158646: LATAUSVIRHE)
Eli, LATAUSVIRHE. Hakemalla suoraan yle-dl:llä tuota jaksoa, jää virheilmoitus pois.

Sain myös seuraavan epämäärisen virheen
Koodi: Valitse kaikki
.assets[][]? | ("https://api.katsomo.fi/api/web/asset/" + .["@id"])
           ^
1 compile error
mutta kun siirsin pois kaikki paitsi late lampaan .vhs-tiedoston, hävisi tuo katsomon virhe. Yritän illalla selvittää mikä .vhs-tiesosto aiheuti tuon katsomo-virheen...

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 14.08.2017 20:38
Kirjoittaja antoine
Pitäisi kai ottaa se Katsomo lopullisesti pois. Nythän he siirtävät kai ohjelmansa vieläpä kirjautumisen taakse, joten tuskin nauhoitusta enää saadaan toimimaan.

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 14.08.2017 20:40
Kirjoittaja antoine
Rene kirjoitti:Toimiiko muilla vhs normaalisti? Saan seuraavan virheen Late Lampaan ja myös muiden Yle:n ohjelmien kohdalla:
Koodi: Valitse kaikki
Late lammas (1-2158646: LATAUSVIRHE)
Eli, LATAUSVIRHE. Hakemalla suoraan yle-dl:llä tuota jaksoa, jää virheilmoitus pois.

Katso mitä lokiin (~/.vhs/Late Lammas/1-2158646.log) tulee, vai tuleeko mitään.

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 14.08.2017 23:20
Kirjoittaja Rene
Jeps, Olihan siellä tällaista..

ffmpeg version 2.5.3- http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2015 the FFmpeg developers
built on Jan 10 2015 09:24:27 with gcc 4.9.2 (Debian 4.9.2-10)
configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame
--enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype
--enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc
--enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --disable-ffserver --enable-libass --enable-gnutls --cc=gcc
libavutil 54. 15.100 / 54. 15.100
libavcodec 56. 13.100 / 56. 13.100
libavformat 56. 15.102 / 56. 15.102
libavdevice 56. 3.100 / 56. 3.100
libavfilter 5. 2.103 / 5. 2.103
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 3.100 / 53. 3.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/root/Movies/vhs/.vhs.yd0D/vhs.flv':
Metadata:
major_brand : isom
minor_version : 512
compatible_brands: isomiso2avc1mp41
encoder : Lavf57.56.100
Duration: 00:07:00.45, start: 0.046440, bitrate: 4030 kb/s
Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 3896 kb/s, 25 fps, 25 tbr, 12800 tbn, 50 tbc (default)
Metadata:
handler_name : VideoHandler
Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 128 kb/s (default)
Metadata:
handler_name : SoundHandler
[aac @ 0x4671bc0] The encoder 'aac' is experimental but experimental codecs are not enabled, add '-strict -2' if you want to use it.
[aac @ 0x4671bc0] Alternatively use the non experimental encoder 'libvo_aacenc'.
Nyt vasta muistin että käytössä tuo ffmpeg-vesio. Pitääpä testata päivittää tuoreempaan versioon, jospa lähtisi paremmin toimimaan :-)

Re: Skripti ylen sarjojen tallennukseen

ViestiLähetetty: 15.08.2017 9:49
Kirjoittaja Rene
Homma korjaantui päivittämällä ffmpeg uuteen versioon :-)