vdr-sxfe ja YLE HD, vdr-sxfe kaatuu välittömästi [RATKAISTU]

HD materiaali 720p/1080i/1080p. Toisto, tallennus & softat.

vdr-sxfe ja YLE HD, vdr-sxfe kaatuu välittömästi [RATKAISTU]

ViestiKirjoittaja Kameleontti » 23.02.2013 17:35

Mikähän mahtaa olla vikana kun vdr-sxfe kaatuu lähestulkoon heti kun kääntää YLE HD:lle (todennäköisesti myös mille tahansa muulle HD-kanavalle). Kuva ja ääni ehtivät välillä näkyä max sekunnin verran. SD-kanavat toimivat jokseenkin kunnolla. Rautana Nvidia GT 220, josta kuva ja ääni hdmi:n kautta telkulle.
Viimeksi muokannut Kameleontti päivämäärä 27.02.2013 20:29, muokattu yhteensä 3 kertaa
Kameleontti
Säätäjä
 
Viestit: 230
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja jarno » 23.02.2013 19:23

Minkälaiset versiot xine-libistä, xineliboutputista ja vdr:stä? Itsellä vdr 1.3.37, xine-lib-1.2 ja xineliboutput git:stä/hg:stä tällä viikolla ja toimii ilman ongelmia. Paitsi tallennuksen kelaaminen. Pistä vaikka pätkä logia siitä kohtaa kun vaihdat kanavaa siihen asti kun kaatuu.
Avatar
jarno
Yli-ihminen
 
Viestit: 527
Liittynyt: 25.06.2005 3:00
Paikkakunta: Tampere

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja Kameleontti » 23.02.2013 19:43

xine-lib-1.2.9999, vdr-xineliboutput-9999, vdr-1.7.36, alustana gentoo, paketit asennettu emergellä vdr-testing ja/tai vdr-devel overlaysta. Jos vielä maltat mainita, että mistä logista tuota kannattaa lähteä tutkimaan?
Kameleontti
Säätäjä
 
Viestit: 230
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja jarno » 23.02.2013 23:15

Kameleontti kirjoitti:Jos vielä maltat mainita, että mistä logista tuota kannattaa lähteä tutkimaan?

Gentoosta en osaa varmaksi sanoa, mutta Debianissa vdr:n viestit menee syslogiin.
Avatar
jarno
Yli-ihminen
 
Viestit: 527
Liittynyt: 25.06.2005 3:00
Paikkakunta: Tampere

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja rofafor » 23.02.2013 23:39

Kameleontti kirjoitti:xine-lib-1.2.9999, vdr-xineliboutput-9999, alustana gentoo

Nämä 9999-versiot ovat ns. live-ebuildeja, joten asennusajankohta on tarpeen, jotta osaat määrittää käytössä olevan version. Voit toki käydä katsomassa ne myös portagen alta suoraan viimeksi haetusta reposta.
Avatar
rofafor
Optikkoliikkeen kopiovastaava
 
Viestit: 1360
Liittynyt: 26.03.2004 3:00
Paikkakunta: Internet

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja Kameleontti » 24.02.2013 10:15

Logipätkää (VDR:n log level = 3):
Koodi: Valitse kaikki
Feb 24 09:10:22 private vdr: [26142] switching to channel 212
Feb 24 09:10:23 private vdr: [26194] osdteletext-receiver thread ended (pid=26142, tid=26194)
Feb 24 09:10:23 private vdr: [26142] buffer stats: 0 (0%) used
Feb 24 09:10:23 private vdr: [26195] TS buffer on device 1 thread ended (pid=26142, tid=26195)
Feb 24 09:10:23 private vdr: [26193] buffer stats: 70688 (1%) used
Feb 24 09:10:23 private vdr: [26193] receiver on device 1 thread ended (pid=26142, tid=26193)
Feb 24 09:10:23 private vdr: [26248] receiver on device 1 thread started (pid=26142, tid=26248, prio=high)
Feb 24 09:10:23 private vdr: [26142] creating directory /var/cache/osdteletext/C-42249-22-2010
Feb 24 09:10:23 private vdr: [26249] osdteletext-receiver thread started (pid=26142, tid=26249, prio=high)
Feb 24 09:10:23 private vdr: [26235] Text2Skin: menu display update thread ended (pid=26142, tid=26235)
Feb 24 09:10:23 private vdr: [26250] Text2Skin: channelInfo display update thread started (pid=26142, tid=26250, prio=high)
Feb 24 09:10:23 private vdr: [26251] TS buffer on device 1 thread started (pid=26142, tid=26251, prio=high)
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264: Found NAL SPS at offset 6/156
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: profile_idc 77
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: pic_width:  120 mbs
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: pic_height: 34 mbs
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: frame only flag: 0
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: cropping 0 0 0 2
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: aspect_ratio_idc 1
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: -> aspect ratio 1 / 1
Feb 24 09:10:23 private vdr: [26248] [xine..put] H.264 SPS: -> video size 1920x1080, aspect 1:1
Feb 24 09:10:23 private vdr: [26248] [xine..put] Detected video size 1920x1080
Feb 24 09:10:25 private vdr: [26182] [xine..put] Client connection 0 closed
Feb 24 09:10:25 private vdr: [26230] [xine..put] cBackgroundWriter: TCP write error
Feb 24 09:10:25 private vdr: [26230] [xine..put]    (ERROR (tools/backgroundwriter.c,247): Virheellinen tiedostokahva)
Feb 24 09:10:25 private vdr: [26182] [xine..put] Closing connection 0
Feb 24 09:10:28 private vdr: [26250] Text2Skin: channelInfo display update thread ended (pid=26142, tid=26250)
Feb 24 09:10:37 private vdr: [26169] channel 10 (TV5) event Su  24.02.2013 09:10-09:15 'TV-Shop ®' status 4
Feb 24 09:10:46 private vdr: [26252] Text2Skin: channelInfo display update thread started (pid=26142, tid=26252, prio=high)
Feb 24 09:10:54 private vdr: [26142] switching to channel 3


Nuo live-ebuildit asennettu testiksi uudelleen juuri ennen testausta ja tuon logipätkän talteenottoa.
Kameleontti
Säätäjä
 
Viestit: 230
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja jarno » 25.02.2013 19:17

Kameleontti kirjoitti:Logipätkää (VDR:n log level = 3):
Koodi: Valitse kaikki
Feb 24 09:10:25 private vdr: [26230] [xine..put] cBackgroundWriter: TCP write error
Feb 24 09:10:25 private vdr: [26230] [xine..put]    (ERROR (tools/backgroundwriter.c,247): Virheellinen tiedostokahva)
Feb 24 09:10:25 private vdr: [26182] [xine..put] Closing connection 0


vdr-sxfe näyttäisi kippaavan tuohon virheelliseen tiedostokahvaan. Jos ajaisit vielä vdr-sxfe:n verbose-vivulla, niin voisi ehkä saada enemmän apuja.
Avatar
jarno
Yli-ihminen
 
Viestit: 527
Liittynyt: 25.06.2005 3:00
Paikkakunta: Tampere

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja Kameleontti » 26.02.2013 16:16

Tässä vielä logia siten, että vdr-sxfe:n --verbose vipu on päällä (ei näytä kertovan mitään uutta):

Koodi: Valitse kaikki
Feb 26 15:14:53 private vdr: [26142] switching to channel 212
Feb 26 15:14:53 private vdr: [12397] osdteletext-receiver thread ended (pid=26142, tid=12397)
Feb 26 15:14:53 private vdr: [26142] buffer stats: 0 (0%) used
Feb 26 15:14:53 private vdr: [12398] TS buffer on device 1 thread ended (pid=26142, tid=12398)
Feb 26 15:14:53 private vdr: [12396] buffer stats: 73508 (1%) used
Feb 26 15:14:53 private vdr: [12396] receiver on device 1 thread ended (pid=26142, tid=12396)
Feb 26 15:14:53 private vdr: [12418] receiver on device 1 thread started (pid=26142, tid=12418, prio=high)
Feb 26 15:14:53 private vdr: [12419] osdteletext-receiver thread started (pid=26142, tid=12419, prio=high)
Feb 26 15:14:53 private vdr: [12417] Text2Skin: menu display update thread ended (pid=26142, tid=12417)
Feb 26 15:14:53 private vdr: [12420] Text2Skin: channelInfo display update thread started (pid=26142, tid=12420, prio=high)
Feb 26 15:14:53 private vdr: [12421] TS buffer on device 1 thread started (pid=26142, tid=12421, prio=high)
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264: Found NAL SPS at offset 6/156
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: profile_idc 77
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: pic_width:  120 mbs
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: pic_height: 34 mbs
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: frame only flag: 0
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: cropping 0 0 0 2
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: aspect_ratio_idc 1
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: -> aspect ratio 1 / 1
Feb 26 15:14:54 private vdr: [12418] [xine..put] H.264 SPS: -> video size 1920x1080, aspect 1:1
Feb 26 15:14:54 private vdr: [12418] [xine..put] Detected video size 1920x1080
Feb 26 15:14:55 private vdr: [26182] [xine..put] Client connection 0 closed
Feb 26 15:14:55 private vdr: [12412] [xine..put] cBackgroundWriter: TCP write error
Feb 26 15:14:55 private vdr: [12412] [xine..put]    (ERROR (tools/backgroundwriter.c,247): Virheellinen tiedostokahva)
Feb 26 15:14:55 private vdr: [26182] [xine..put] Closing connection 0
Kameleontti
Säätäjä
 
Viestit: 230
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja noeikujoo » 26.02.2013 17:02

Minulla ainakin vdr-sxfe kaatui aina Yle HD kanavalle siirryttäessä, kun passthrough device:ä ei oltu määritetty .xine/config_xineliboutput-tiedostossa. Yle HD kanavalla on käytössä Dolby Digital-ääni ja passthrough device piti olla määritettynä, että vdr-sxfe ei kaadu. Äänen ulostulona toimi GeForce GT220:n HDMI (pass through) lähtö.
Avatar
noeikujoo
Yli-ihminen
 
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja Kameleontti » 26.02.2013 21:55

Pystytkö laittamaan mallin miten tuo määritellään kyseiseen konffiin?
Kameleontti
Säätäjä
 
Viestit: 230
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja jarno » 26.02.2013 21:57

Kameleontti kirjoitti:Pystytkö laittamaan mallin miten tuo määritellään kyseiseen konffiin?

Koodi: Valitse kaikki
jarno@htpc:~$ cat .xine/config_xineliboutput|grep passth
audio.device.alsa_passthrough_device:hdmi
jarno@htpc:~$
Avatar
jarno
Yli-ihminen
 
Viestit: 527
Liittynyt: 25.06.2005 3:00
Paikkakunta: Tampere

Re: vdr-sxfe ja YLE HD

ViestiKirjoittaja noeikujoo » 27.02.2013 7:45

Minulla toimii seuraavilla asetuksilla.

Vdr-sxfe:n käynnistysparametri:
Koodi: Valitse kaikki
--audio=alsa:plughw:CARD=NVidia,DEV=7


.xine/config_xineliboutput:
Koodi: Valitse kaikki
# device used for 5.1-channel output
# string, default: iec958:AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2
audio.device.alsa_passthrough_device:plughw:CARD=NVidia,DEV=7
Avatar
noeikujoo
Yli-ihminen
 
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

Re: vdr-sxfe ja YLE HD, vdr-sxfe kaatuu välittömästi

ViestiKirjoittaja Kameleontti » 27.02.2013 17:29

Nyt ollaan jäljillä. Tuo pelkän hdmi:n .xine/config_xineliboutput:iin lisääminen sai kuvan näkyviin, mutta ääni ei kuulu. Pitääkö sama asetus antaa myös vdr-sxfe:n starttikäskyn parametrina?

noeikujoo: Mistä tuo asetuksesi DEV=7 määre on saatu, vai onko se kaikilla sama?
Kameleontti
Säätäjä
 
Viestit: 230
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Re: vdr-sxfe ja YLE HD, vdr-sxfe kaatuu välittömästi

ViestiKirjoittaja perusmuro » 27.02.2013 18:07

Kameleontti kirjoitti:noeikujoo: Mistä tuo asetuksesi DEV=7 määre on saatu, vai onko se kaikilla sama?


Aja terminaalissa komento aplay -l, se listaa sun äänilaitteet.
yaVDR 0.6
perusmuro
Säätäjä
 
Viestit: 238
Liittynyt: 25.04.2011 15:00

Re: vdr-sxfe ja YLE HD, vdr-sxfe kaatuu välittömästi

ViestiKirjoittaja Kameleontti » 27.02.2013 18:38

aplay -l:
Koodi: Valitse kaikki
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Mikäs noista nyt sit on oikea? Näköjään mulla on /etc/asound.confissa määritelty jotain tuollaista aikoinaan, että sai toimimaan äänet yleensäkään:
Koodi: Valitse kaikki
pcm.!default {
type hw
card 0
device 7
}
Kameleontti
Säätäjä
 
Viestit: 230
Liittynyt: 03.09.2007 11:09
Paikkakunta: Hellsinki

Seuraava

Paluu Linux & HDTV

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 1 vierailijaa

cron