YLE HD, tosin vain urheilua

HD materiaali 720p/1080i/1080p. Toisto, tallennus & softat.

ViestiKirjoittaja noeikujoo » 12.02.2010 21:28

Lumotv:n kaapeliverkossa ei myöskään Yle HD näy vdr-sxfe:n kautta. Lähes joka kerta vdr-sxfe kaatuu, kun vaihtaa Yle HD:lle. Pari kertaa sain kuvan näkymään, mutta se oli ihan palikoitunut. PS3 näyttää streamdev:n lähettämän striimin ongelmitta. Bitrate näyttää olevan 18-20 Mbps. Ilmeisesti tuo Yle HD:n kuva ei oikein toimi VDPAU:lla tms. Nelonen HD ja Suomi-TV HD toimivat vdr-sxfe:n kautta.
Avatar
noeikujoo
Yli-ihminen
 
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

ViestiKirjoittaja mytty » 12.02.2010 21:35

mytty kirjoitti:Kuka osais kertoa miltä taajuudelta löytyy Welhon verkossa? Jollakulla heittää parametririmpsua?


Löytyikin MythTV:llä "Search Existing Transports":illa. :)

Ilmeisesti auttoi kun laittoi täpän "Ignore Signal Timeout" -kohtaan haun yhteydessä.
mytty
Amatööri
 
Viestit: 15
Liittynyt: 11.02.2010 17:52

ViestiKirjoittaja svassi » 12.02.2010 22:50

noeikujoo kirjoitti:Lumotv:n kaapeliverkossa ei myöskään Yle HD näy vdr-sxfe:n kautta. Lähes joka kerta vdr-sxfe kaatuu, kun vaihtaa Yle HD:lle. Pari kertaa sain kuvan näkymään, mutta se oli ihan palikoitunut. PS3 näyttää streamdev:n lähettämän striimin ongelmitta. Bitrate näyttää olevan 18-20 Mbps. Ilmeisesti tuo Yle HD:n kuva ei oikein toimi VDPAU:lla tms. Nelonen HD ja Suomi-TV HD toimivat vdr-sxfe:n kautta.

ootko muuten kokeillut saatko mplayerillä kuvan näkymään ilman että kerrot mpläyerille fps arvoa. mplayer toimii -vo vdpau vivulla ihan ok. Jotenkin mulla kääntyy sormi nyt osoittamaan VDR-Teamin reposta saatavia *xine* paketteja tai sitten striimissä on jotain vikaa, mutta miks se tuntuu toimivan televisioiden virittimillä... Mitens ne kellä tuo toimii onks systeemit käsin rakennettu vai jostain pakettihallinnan kautta asennettu.
GA-H97M-D3H | i3 4150 | 2*2G | 1T | 2*Cinergy1200-C | GT 210 | Fusion 430W | Logitech K400 | VDR 2.2.0 (yaVDR-stable) | Sony KDL46EX723 + sekalainen seurakunta streamdev-clienttejä
Avatar
svassi
Säätäjä
 
Viestit: 267
Liittynyt: 08.11.2007 16:15
Paikkakunta: Jyväskylä

ViestiKirjoittaja hetas » 13.02.2010 0:02

Ei näy täälläkään kunnolla vdr-sxfe:llä ja vdpaulla. Kuva menee palikkamössöksi. XBMC:n VDR pluginilla, joka toistaa streamdev-striimiä, kuva on OK vdpauta käytettäessä.

EDIT: VDR on 1.7.10, xine-lib ja xbmc on versionhallinnasta. Kaikki itse käännetty. Nvidian ajurit on 195-beta sarjaa. XBMC:n VDR plugin löytyi jostain foorumilta.
hetas
Yli-ihminen
 
Viestit: 536
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

ViestiKirjoittaja svassi » 13.02.2010 9:29

Mediainfo ohjelma antaa seuraavanlaiset tulosteet YLE HD tallenteesta ja 4HD tallenteesta.
Nelonen HD
YLE HD
Ensimmäisenä silmään pistävät erot tallenteissa on:
YLE
Codec profile : High@L4.1
Scan type : MBAFF
Scan type : MBAFF
Interlacement : MBAFF
Interlacement : MBAFF

Nelonen HD
Codec profile : Main@L4.0
Scan type : Interlaced
Scan type : Interlaced
Scan order : TFF
Scan order : Top Field First
Interlacement : TFF
Interlacement : Top Field First

EDIT: Vertailun vuoksi vielä CanalDigitalin kautta tulevan striimin tiedot http://pastebin.com/m3fec8802 (thx Jack73). CDllä kuva on High@4.0 ja Interlaced/Top Field First. Olisiko syypäänä tuo MBAFF? Mitähän DNA laittaa DVB-T jakelussa
Mediainfo löytyy Ubuntuun täältä.
GA-H97M-D3H | i3 4150 | 2*2G | 1T | 2*Cinergy1200-C | GT 210 | Fusion 430W | Logitech K400 | VDR 2.2.0 (yaVDR-stable) | Sony KDL46EX723 + sekalainen seurakunta streamdev-clienttejä
Avatar
svassi
Säätäjä
 
Viestit: 267
Liittynyt: 08.11.2007 16:15
Paikkakunta: Jyväskylä

ViestiKirjoittaja noeikujoo » 13.02.2010 11:57

Myös Windows-koneilla streamdev:n lähettämä Yle HD on VNC:llä ihan sotkua:

Kuva

Ainoastaan PS3 näyttää tuon kuvan oikein. Mplayerilla ei ole kokeillut, kun koneella ei ole sellaista versiota, joka tukisi VDPAU:ta.
Avatar
noeikujoo
Yli-ihminen
 
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

ViestiKirjoittaja hetas » 13.02.2010 12:07

Joku omituista tuossa Elisan YLE HD-kanavassa on. VDR ei tosiaan näytä kunnolla, mutta XBMC:llä näkyy. Mutta välillä kanavalle vaihdettaessa XBMC alkaa syödä prosessoriaikaa aivain kuin purkaisi videota softalla. Välillä taas toimii normaalisti, eli prosessorin käyttö on minimissä.

XBMC näyttää myös tiputtavan freimejä aika reippaasti silloin kun prosessoria ei kuormiteta. Käykö tässä nyt yksinkertaisesti niin, että näytönohjaimesta loppuu potku kesken tuolla bitratella? Muissa ketjuissa on ollut puhetta näytönohjainten muistiväylistä ja muistien nopeuksista.

Näytönohjaimena on MSI:n N220GT. Muistiväylä on 128-bittinen, mutta muisti on hitaampaa DDR2:sta.
hetas
Yli-ihminen
 
Viestit: 536
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

ViestiKirjoittaja svassi » 13.02.2010 13:46

Laitoin Elisalle vikailmoituksen kautta kyselyn, mitä on muuttunut taitoluistelun EM-kisojen ja Vancouverin Olympialaisten aikana. Saapa nähdä tuleeko vastaus ennen vappua.
GA-H97M-D3H | i3 4150 | 2*2G | 1T | 2*Cinergy1200-C | GT 210 | Fusion 430W | Logitech K400 | VDR 2.2.0 (yaVDR-stable) | Sony KDL46EX723 + sekalainen seurakunta streamdev-clienttejä
Avatar
svassi
Säätäjä
 
Viestit: 267
Liittynyt: 08.11.2007 16:15
Paikkakunta: Jyväskylä

ViestiKirjoittaja noeikujoo » 13.02.2010 17:24

hetas kirjoitti:Käykö tässä nyt yksinkertaisesti niin, että näytönohjaimesta loppuu potku kesken tuolla bitratella? Muissa ketjuissa on ollut puhetta näytönohjainten muistiväylistä ja muistien nopeuksista.

Enpä usko.. Itsellä ainakin integroidun GF 9300 näyttiksen tehon loppuminen ilmenee kuvan hidastumisena. Jos laitan HD:lle temporal spatial lomituksenpoiston päälle, niin kuvanopeus vaan hidastuu. Kuva näyttää siltä, kuin fps olis jotain 15 kuvaa/s luokkaa. Vdr-sxfe ei kaadu ja kuva näkyy muuten normaalisti. Joitain erikoista tuossa Yle HD:n kuvassa täytyy olla. Osaisikohan joku asioista enemmän perillä oleva selvittää tätä ongelmaa, jos tuota lähetystä ottaisi pätkän talteen levylle? Esim. vdr-sxfe:n kehittäjä?
Avatar
noeikujoo
Yli-ihminen
 
Viestit: 2156
Liittynyt: 23.08.2004 3:00
Paikkakunta: Kajaani

ViestiKirjoittaja micsa » 13.02.2010 21:44

hetas kirjoitti:Joku omituista tuossa Elisan YLE HD-kanavassa on.


Olen samaa mieltä. Laitoin tänään aamulla avajaisten aikaan tarkempaa kuvausta virheistä tuohon viereiseen threadiin:

http://www.linuxtv.fi/viewtopic.php?p=25464#25464

Mulla ei siis toimi streamdevin yli edes PS3:ssa. NelonenHD (joka ei vaadi Elisan korttia) toimii hienosti.

Onko mahdollista että Elisa olisi aktivoinut korttilinkityksen myös YleHD:lle? Tuo voisi olla loogista siitä näkökulmasta, että ilmeisesti myös Eurosport HD vaatii korttilinkityksen.

Siitä kuitenkin olen varma, että vielä viikko-pari sitten YleHD:n testikuva tuli Elisan verkossa kokonaan ilman salausta.
Avatar
micsa
Vanhempi harrastaja
 
Viestit: 76
Liittynyt: 05.11.2004 3:00
Paikkakunta: Kirkkonummi

ViestiKirjoittaja hetas » 13.02.2010 22:11

micsa kirjoitti:Onko mahdollista että Elisa olisi aktivoinut korttilinkityksen myös YleHD:lle?

Ei ole ainakaan minulla korttilinkitetty. Kanava siis näkyy VDR:llä, eikä kaada vdr-sxfe:tä, mutta kuvassa on paljon häiriöitä. Streamdev/XBMC yhdistelmällä näkyy paremmin. Korttilinkitetty EurosportHD ei näy SoftCamilla ollenkaan, mutta näkyy Sonyn telkkarilla.

Ei näytä kovin hyvin mitkään mediasoittimet XBMC:tä lukuunottamatta toistavan kanavan tallennetta, joten ilmeisesti striimi vain jotenkin erikoista. Svassin postaamissa mediainffoissa mainittu MBAFF kirjainyhdistelmä palauttelee googlessa jotain, mutta kun en paljoa noista ymmärrä.
hetas
Yli-ihminen
 
Viestit: 536
Liittynyt: 15.07.2004 3:00
Paikkakunta: Savonlinna

ViestiKirjoittaja svalavuo » 13.02.2010 22:48

xbmc toistaa, vdr-sxfe kaatuu
PS3:sta en ole ehtinyt kokeilemaan.

Ollee jotain tuskaa VDPAU -tuessa sxfe:ssä?
Ja ainakaan Raumalla DNA:n kaapelissa ei ole likitetty.
Avatar
svalavuo
Säätäjä
 
Viestit: 283
Liittynyt: 07.12.2004 3:00
Paikkakunta: Rauma

ViestiKirjoittaja jms-linuxtv » 14.02.2010 9:09

Näyttää vähän kokemukset vaihtelevan, mulla näkyy loistavasti MythFE:llä Elisan välittämä YleHD:
Codec profile : High@L4.1
Scan type : MBAFF
Interlacement : MBAFF

...mutta taas XBMC:llä sama lähetys samassa raudassa tökkii reilusti. Palvelin on erillinen Mythtv.
jms-linuxtv
Harrastaja
 
Viestit: 43
Liittynyt: 15.12.2009 14:52
Paikkakunta: Tampere

ViestiKirjoittaja rofafor » 14.02.2010 10:02

Xine-libin VDPAU-toteutuksessa ei ole MBAFF-tukea - asiasta kannattaa mussuttaa suoraan kehittäjille ja tarjota samalla näytepalaa toimimattomasta H.264-tiedostosta.
Avatar
rofafor
Optikkoliikkeen kopiovastaava
 
Viestit: 1365
Liittynyt: 26.03.2004 3:00
Paikkakunta: Internet

ViestiKirjoittaja svalavuo » 14.02.2010 10:25

rofafor kirjoitti:Xine-libin VDPAU-toteutuksessa ei ole MBAFF-tukea - asiasta kannattaa mussuttaa suoraan kehittäjille ja tarjota samalla näytepalaa toimimattomasta H.264-tiedostosta.


No tuohan selittää paljon. Ei ole bugi, vaan ominaisuus :)
Avatar
svalavuo
Säätäjä
 
Viestit: 283
Liittynyt: 07.12.2004 3:00
Paikkakunta: Rauma

EdellinenSeuraava

Paluu Linux & HDTV

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 1 vierailijaa