vdr 2.3.x

VDR ja DVB aiheista keskustelua

Re: vdr 2.3.x

ViestiKirjoittaja Rene » 03.09.2017 13:22

Rene kirjoitti:
Rene kirjoitti:Testaan vielä lisäämällä linkin tuohon oikeaan headeriin /usr/src/linux -> linux-headers-3.13.0-117 kuten gentoossa on..
Noup.. eipä auttanut :-( Mutta.. tuo on kyl mukana headereissä..
# grep -r DTV_STAT_SIGNAL_STRENGTH /usr/src/linux/*
/usr/src/linux/include/uapi/linux/dvb/frontend.h:#define DTV_STAT_SIGNAL_STRENGTH 62

Noni.. taisin keksiä ratakisun.. laitoin Make.config:n DVB-muuttujaksi /usr/local/src/media_build/linux/include/uapi (sorsat hain täältä: https://git.linuxtv.org/media_build.git).. :-)
Avatar
Rene
Yli-ihminen
 
Viestit: 638
Liittynyt: 10.10.2004 3:00
Paikkakunta: Espoo

Re: vdr 2.3.x

ViestiKirjoittaja rofafor » 03.09.2017 19:41

User space headerisi eivät ole kääntäjän oletuspolussa ja siksi käännös ei toimi. Kernel hearedeiden asennuksen myötä, ne pitäisi löytyä suunnilleen täältä: /usr/include/linux/dvb/frontend.h
Avatar
rofafor
Optikkoliikkeen kopiovastaava
 
Viestit: 1365
Liittynyt: 26.03.2004 3:00
Paikkakunta: Internet

Re: vdr 2.3.x

ViestiKirjoittaja Rene » 03.09.2017 23:13

rofafor kirjoitti:User space headerisi eivät ole kääntäjän oletuspolussa ja siksi käännös ei toimi. Kernel hearedeiden asennuksen myötä, ne pitäisi löytyä suunnilleen täältä: /usr/include/linux/dvb/frontend.h
Jeps.. sieltähän se hakemisto löytyi (/usr/include/linux/dvb), mutta se sisältää vanhan version frontend.h:sta.. Selvitin että /usr/include/linux/dvb/frontend.h-tiedosto kuuluu linux-libc-dev-pakettiin, ja löytyihän siihen sit sama versio kun itse kerneli (https://launchpad.net/ubuntu/trusty/amd ... .0-117.164). Aika sekasotkuksi meni nyt tää mun Precise-distro kun muutama paketti kuuluu Trusty:lle :-) Mut pääasia että vdr kääntyy! :-)
Avatar
Rene
Yli-ihminen
 
Viestit: 638
Liittynyt: 10.10.2004 3:00
Paikkakunta: Espoo

Re: vdr 2.3.x

ViestiKirjoittaja ppaalto » 05.09.2017 7:12

ppaalto
Asiantuntija
 
Viestit: 141
Liittynyt: 02.12.2005 23:38

Re: vdr 2.3.x

ViestiKirjoittaja Rene » 05.09.2017 7:32

Näyttää lopulta nyt siltä että päivitys jää tekemättä kun EnigmaNG-skini ei enää käänny :-( Joskus yrittänyt vaihtaa ulkonäön toiseen, mutta muu väki ei katsotonut asiaa kovin hyvällä...
Avatar
Rene
Yli-ihminen
 
Viestit: 638
Liittynyt: 10.10.2004 3:00
Paikkakunta: Espoo

Re: vdr 2.3.x

ViestiKirjoittaja P.Kosunen » 05.09.2017 11:49

ppaalto kirjoitti:Nykyiset gitit 2.3.8:ssa

Koodi: Valitse kaikki
git clone -b vpp_support git://github.com/rofafor/vdr-plugin-softhddevice


+Rofaforin softhdddevice plugin joka tukee mm. VA-API rauta-lomituksenpoistoja ainakin Intelin kanssa.
P.Kosunen
Yli-ihminen
 
Viestit: 1131
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Re: vdr 2.3.x

ViestiKirjoittaja ppaalto » 06.09.2017 21:49

Saksan vdr-portal on siis alku ja juuri...
https://www.vdr-portal.de/forum/index.p ... ng-plugin/
PasiA
ppaalto
Asiantuntija
 
Viestit: 141
Liittynyt: 02.12.2005 23:38

Re: vdr 2.3.x

ViestiKirjoittaja Rene » 07.09.2017 9:39

ppaalto kirjoitti:Saksan vdr-portal on siis alku ja juuri...
https://www.vdr-portal.de/forum/index.p ... ng-plugin/
PasiA
Jeps, ja sain vastauksen erittäin nopeasti :-) Nyt mulla pyörii 2.3.8 melkein kaikilla plugineilla paitsi streamdev-plugini joka kyllä kääntyy, mutta kaatuu virheeseen
Koodi: Valitse kaikki
ERROR: /data/home/vdr_ubuntu/vdr-2.3.8/PLUGINS/lib/libvdr-streamdev-server.so.2.3.8: undefined symbol: Timers
:-(
Avatar
Rene
Yli-ihminen
 
Viestit: 638
Liittynyt: 10.10.2004 3:00
Paikkakunta: Espoo

Re: vdr 2.3.x

ViestiKirjoittaja P.Kosunen » 07.09.2017 12:09

"undefined symbol" virheitä tulee ainakin, kun kääntää eri version headereitä vastaan.
P.Kosunen
Yli-ihminen
 
Viestit: 1131
Liittynyt: 06.11.2005 14:08
Paikkakunta: Helsinki

Re: vdr 2.3.x

ViestiKirjoittaja Rene » 07.09.2017 12:13

P.Kosunen kirjoitti:"undefined symbol" virheitä tulee ainakin, kun kääntää eri version headereitä vastaan.
Nyt pitäisi olla kaikki headerit samaa versiota, sillä poistin vanhat mitkä vielä pyöri nurkissa.
Koodi: Valitse kaikki
root@htpc:~# dpkg --list |grep '3.13.0'
ii  linux-generic-lts-trusty                                    3.13.0.117.108                                      Generic Linux kernel image and headers
ii  linux-headers-3.13.0-117                                    3.13.0-117.164~precise1                             Header files related to Linux kernel version 3.13.0
ii  linux-headers-3.13.0-117-generic                            3.13.0-117.164~precise1                             Linux kernel headers for version 3.13.0 on 64 bit x86 SMP
ii  linux-headers-generic-lts-trusty                            3.13.0.117.108                                      Generic Linux kernel headers
ii  linux-image-3.13.0-117-generic                              3.13.0-117.164~precise1                             Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-generic-lts-trusty                              3.13.0.117.108                                      Generic Linux kernel image
ii  linux-libc-dev                                              3.13.0-117.164                                      Linux Kernel Headers for development
ii  linux-lts-trusty-tools-3.13.0-117                           3.13.0-117.164~precise1                             Linux kernel version specific tools for version 3.13.0-117
ii  linux-tools-3.13.0-117-generic                              3.13.0-117.164~precise1                             Linux kernel version specific tools for version 3.13.0-117
ii  linux-tools-lts-trusty                                      3.13.0.117.108                                      Linux kernel versioned Tools
Avatar
Rene
Yli-ihminen
 
Viestit: 638
Liittynyt: 10.10.2004 3:00
Paikkakunta: Espoo

Re: vdr 2.3.x

ViestiKirjoittaja nm » 08.09.2017 1:58

Rene kirjoitti:
P.Kosunen kirjoitti:"undefined symbol" virheitä tulee ainakin, kun kääntää eri version headereitä vastaan.
Nyt pitäisi olla kaikki headerit samaa versiota, sillä poistin vanhat mitkä vielä pyöri nurkissa.

Kernelin headereilla ei ole tässä merkitystä. Varmista, että plugari kääntyy oikeita VDR:n headereita vasten.
nm
Johtava konsultti
 
Viestit: 3160
Liittynyt: 22.07.2005 3:00

Re: vdr 2.3.x

ViestiKirjoittaja tikola » 16.10.2017 16:32

Tänään testikoneeseen asentamassani uudessa 17.10 Ubuntussa on suoraan pakettivarastosta 2.3 sarjan VDR sisältäen kaikki minulle kriittiset plugarit, joita minulle ennen kaikkea ovat StreamDev-Server, VNSI, EPGSearch ja Live. Lisäksi toissijaisia tarpeitani, kuten Xineliboutput ja Femon löytyy, joten haiskahtaa vahvasti sille, että tässä tulee pikkuhiljaa muutos VDR 2.3 maailmaan. Tosin pitänee rakentaa uusi serveri ensin loppuun eikä vain päivittää vanhaa, koska toimivaa tuotantoyksikköä ei koskaan pidä ihan tuosta vaan mennä päivittämään.

Jään mielenkiinnolla odottamaan miten tämä oikeasti toimii, koska nykyinen 2.2 ja Ubuntu 16.04:n päällä toimii kyllä aika vakaasti ja ongelmitta, joskin muutamaan detaljiin kaipailen sitä uudempaa versiota. Lähinnä tuo epgsearch on se kaikkein kriittisin - muiden kanssa pärjäilen, mutta sen olisi syytä hoitaa hommansa mahdollisimman hyvin. Raportoin tänne kun pääsen hommassa niin pitkälle, että jotain kokemuksia on.

https://packages.ubuntu.com/search?suite=default&section=all&arch=any&lang=fi&keywords=vdr&searchon=names

Eli minulla ainakin muutos 2.2 maailmasta 2.3 maailmaan alkaa olla ihan kolkuttelemassa ovelle. Ensimmäisen 17.10 Ubuntu maistiaisen jälkeen ajattelin kyllä ottaa muutaman kuukauden aikalisän, koska siinä tuntuu olevan ihan perusasioiden vakaudessa vielä pikkuisen puutteita. Ilmeisesti se Unity-Gnome muunnos ei ole ihan helppo.

timo
tikola
Säätäjä
 
Viestit: 226
Liittynyt: 31.03.2009 11:35
Paikkakunta: Vantaa

Edellinen

Paluu VDR & DVB

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 4 vierailijaa

cron