yaVDR cine rikki

VDR ja DVB aiheista keskustelua

yaVDR cine rikki

ViestiKirjoittaja Miika » 23.08.2015 18:10

Ajoin apt-get upgraden yavdr asennukselle, jonka seurauksena media-build-experimental näyttäisi menneen rikki.

Koodi: Valitse kaikki
Upgrade: openssh-server:amd64 (5.9p1-5ubuntu1.4, 5.9p1-5ubuntu1.7),
bind9-host:amd64 (9.8.1.dfsg.P1-4ubuntu0.11, 9.8.1.dfsg.P1-4ubuntu0.12),
openjdk-7-jre:amd64 (7u79-2.
5.5-0ubuntu0.12.04.1, 7u79-2.5.6-0ubuntu1.12.04.1), libdns81:amd64 (9.8.1.dfsg.P1-4ubuntu0.11, 9.8.1.dfsg.P1-4ubuntu0.12), libpcre3:amd64 (8.12-4, 8.12-4ubuntu0.1), dvb-
driver-sundtek-mediaclient:amd64 (20150630.105834-1yavdr1~precise, 20150728.175535-1yavdr1~precise), libgs9-common:amd64 (9.05~dfsg-0ubuntu4.2, 9.05~dfsg-0ubuntu4.3), li
bapt-inst1.4:amd64 (0.8.16~exp12ubuntu10.24, 0.8.16~exp12ubuntu10.25), libmysqlclient18:amd64 (5.5.43-0ubuntu0.12.04.1, 5.5.44-0ubuntu0.12.04.1), libisccc80:amd64 (9.8.1
.dfsg.P1-4ubuntu0.11, 9.8.1.dfsg.P1-4ubuntu0.12), apt-utils:amd64 (0.8.16~exp12ubuntu10.24, 0.8.16~exp12ubuntu10.25), libpcrecpp0:amd64 (8.12-4, 8.12-4ubuntu0.1), apt:am
d64 (0.8.16~exp12ubuntu10.24, 0.8.16~exp12ubuntu10.25), firefox:amd64 (38.0+build3-0ubuntu0.12.04.1, 40.0+build4-0ubuntu0.12.04.4), liblwres80:amd64 (9.8.1.dfsg.P1-4ubun
tu0.11, 9.8.1.dfsg.P1-4ubuntu0.12), openssh-client:amd64 (5.9p1-5ubuntu1.4, 5.9p1-5ubuntu1.7), tzdata-java:amd64 (2015d-0ubuntu0.12.04, 2015f-0ubuntu0.12.04), media-buil
d-experimental-dkms:amd64 (0~20140416.220630-1yavdr1~precise, 0~20150719.122100-1yavdr1~precise), libbind9-80:amd64 (9.8.1.dfsg.P1-4ubuntu0.11, 9.8.1.dfsg.P1-4ubuntu0.12
), libapt-pkg4.12:amd64 (0.8.16~exp12ubuntu10.24, 0.8.16~exp12ubuntu10.25), xul-ext-ubufox:amd64 (3.0-0ubuntu0.12.04.1, 3.1-0ubuntu0.12.04.1), ssh:amd64 (5.9p1-5ubuntu1.
4, 5.9p1-5ubuntu1.7), libgs9:amd64 (9.05~dfsg-0ubuntu4.2, 9.05~dfsg-0ubuntu4.3), libisccfg82:amd64 (9.8.1.dfsg.P1-4ubuntu0.11, 9.8.1.dfsg.P1-4ubuntu0.12), tzdata:amd64 (
2015d-0ubuntu0.12.04, 2015f-0ubuntu0.12.04), ghostscript:amd64 (9.05~dfsg-0ubuntu4.2, 9.05~dfsg-0ubuntu4.3), linux-libc-dev:amd64 (3.2.0-87.125, 3.2.0-89.127), sqlite3:a
md64 (3.7.9-2ubuntu1.1, 3.7.9-2ubuntu1.2), libisc83:amd64 (9.8.1.dfsg.P1-4ubuntu0.11, 9.8.1.dfsg.P1-4ubuntu0.12), mysql-common:amd64 (5.5.43-0ubuntu0.12.04.1, 5.5.44-0ub
untu0.12.04.1), libsqlite3-0:amd64 (3.7.9-2ubuntu1.1, 3.7.9-2ubuntu1.2), openjdk-7-jre-headless:amd64 (7u79-2.5.5-0ubuntu0.12.04.1, 7u79-2.5.6-0ubuntu1.12.04.1), adobe-f
lashplugin:amd64 (20150708.1-0precise1, 20150811.1-0precise1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2015-08-23  17:10:29


Cine ajuria ei enää näy bootissa ja yavdr on melko murheellinen signaalinpuuttumisen osalta, mikä on tietysti ymmärrettävää, jos dvb ajuri ei ole latautunut oikein. Yritin asentaa paketin käsin:

Koodi: Valitse kaikki
 sudo dpkg -i /tmp/media-build-experimental-dkms_0~20150719.122100-1yavdr1~precise_all.deb


mutta lopputulos on tämä:
Koodi: Valitse kaikki
Selecting previously unselected package media-build-experimental-dkms.
(Luetaan tietokantaa... 108798 files and directories currently installed.)
Puretaan pakettia media-build-experimental-dkms (.../media-build-experimental-dkms_0~20150719.122100-1yavdr1~precise_all.deb)...
Tehdään asetuksia: media-build-experimental-dkms (0~20150719.122100-1yavdr1~precise) ...
Loading new media-build-experimental-0~20150719.122100 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-65-generic
Building for architecture x86_64
Building initial module for 3.2.0-65-generic
Error!  Build of adp1653.ko failed for: 3.2.0-65-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/media-build-experimental/0~20150719.122100/build/ for more information.
dpkg: virhe käsiteltäessä media-build-experimental-dkms (--install):
 aliprosessi komentotiedosto post-installation asennettu palautti virhetilakoodin 7
Käsittelyssä tapahtui liian monta virhettä:
 media-build-experimental-dkms


Onko hyviä neuvoja, jolla media-build-experimental-dkms saisi taas toimivaan kuntoon?
Avatar
Miika
Säätäjä
 
Viestit: 334
Liittynyt: 22.09.2003 3:00
Paikkakunta: Jyväskylä

Re: yaVDR cine rikki

ViestiKirjoittaja Miika » 23.08.2015 18:55

Itse itselleni vastaten. Latasin edellisen version:

https://launchpad.net/~yavdr/+archive/ubuntu/main/+packages?field.name_filter=media-build-experimental-dkms&field.status_filter=&field.series_filter=precise

ja tarkemmin:

https://launchpad.net/~yavdr/+archive/ubuntu/main/+files/media-build-experimental-dkms_0~20140416.220630-1yavdr1~precise_all.deb

Ilmeisesti 3.2.0-65-generic #99-Ub ja media-build-experimental-dkms - 0~20150719.122100-1yavdr1~precise eivät puhu samaa murretta.

Jatkossa olisi hyvä selvittää a) miten merkkaan apt-getille, ettei media-build-experimental-dkms saa päivittää b) mitä yadr-0.5.0a osalta tulisi tehdä, että uudempi media-build-experimental-dkms asentuisi oikein / ilman herjoja.
Avatar
Miika
Säätäjä
 
Viestit: 334
Liittynyt: 22.09.2003 3:00
Paikkakunta: Jyväskylä

Re: yaVDR cine rikki

ViestiKirjoittaja nm » 24.08.2015 1:50

Miika kirjoitti:Jatkossa olisi hyvä selvittää a) miten merkkaan apt-getille, ettei media-build-experimental-dkms saa päivittää

Esimerkkejä eri menetelmistä: http://askubuntu.com/questions/18654/ho ... 8656#18656


Miika kirjoitti:b) mitä yadr-0.5.0a osalta tulisi tehdä, että uudempi media-build-experimental-dkms asentuisi oikein / ilman herjoja.

Tuo uusi media-build-experimental-dkms vaatinee uudemman kernelin. 3.13-sarjan kerneli varmaankin kävisi, jolloin voit päivittää tämän ohjeen mukaan: https://wiki.ubuntu.com/Kernel/LTSEnablementStack

Koodi: Valitse kaikki
sudo apt-get install --install-recommends linux-generic-lts-trusty xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty



VDR-portalissa on hieman keskustelua samasta asiasta: http://www.vdr-portal.de/index.php?page ... ID=1251112
nm
Johtava konsultti
 
Viestit: 3160
Liittynyt: 22.07.2005 3:00


Paluu VDR & DVB

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 1 vierailijaa